[Haskell-cafe] Re: Sifflet dependencies

Andrew Coppin andrewcoppin at btinternet.com
Tue Aug 17 14:54:13 EDT 2010

Don Stewart wrote:
> Those specific versions of packages are overly constrained. They should follow the PVP.

While we're on the subject... Suppose I have a package, which I know 
works with foo-8.7.2. What should the Cabal dependents field say? We 
have a choice of

  foo == 8.7.2
  foo >= 8.7.2
  foo >= 8.7
  foo >= 8.7 && < 8.8
  foo == 8.7.*

So which one is the "correct" one? Based on your responses, I'm guessing 
it's supposed to be the last one...

More information about the Haskell-Cafe mailing list