[Haskell-cafe] ghc package problem

Phyx lonetiger at gmail.com
Fri Apr 16 18:31:29 EDT 2010

I've tried your suggestion, and with the --global flag it does work, but
only if I keep using the global flag, when I just install as user again same
thing happens. Maybe something's wrong with the user package conf.

Unfortunately installing as global requires admin rights and installs the
tools as admins only, so I don't really want to continue using it like that.

-----Original Message-----
From: thebenmachine at googlemail.com [mailto:thebenmachine at googlemail.com] On
Behalf Of Ben Millwood
Sent: Friday, April 16, 2010 20:57
To: Phyx
Cc: Ivan Lazar Miljenovic; haskell-cafe at haskell.org
Subject: Re: [Haskell-cafe] ghc package problem

On Fri, Apr 16, 2010 at 2:40 PM, Phyx <lonetiger at gmail.com> wrote:
> So same error. This isn't just limited to HSE though, it can't find 
> packages like random,time etc either. Keeps reinstalling them on every
cabal install.

>    QuickCheck-
>    WinDll-0.1.9
>    cpphs-1.11
>    ghc-paths-
>    haskell-src-exts-1.9.0
>    haskell98-
>    mtl-
>    random-
>    syb-
>    tar-
>    time-

So every package you are having problems with is in your user package list?
Perhaps there is some disagreement in either Cabal or GHC or both as to
where those packages/that package file should be? Perhaps try a cabal
install --global haskell-src-exts and see if that makes a difference, or
attach --user to a configure command.

More information about the Haskell-Cafe mailing list