[Haskell-cafe] Difficulties installing LLVM bindings

Aran Donohue aran.donohue at gmail.com
Fri Apr 9 13:38:21 EDT 2010

Hi Haskell-Cafe,

I can't get the LLVM bindings for Haskell to install. Does anyone know what
I might need to do? Has anyone seen this error before?

Here's the problem: (Installing from latest darcs source)
llvm-haskell aran$ cabal install
Resolving dependencies...
checking for unistd.h... yes
checking llvm-c/Core.h usability... yes
checking llvm-c/Core.h presence... yes
checking for llvm-c/Core.h... yes
checking for LLVMModuleCreateWithName in -lLLVMCore... no
configure: error: could not find LLVM C bindings
cabal: Error: some packages failed to install:
llvm- failed during the configure step. The exception was:
exit: ExitFailure 1

I've got the latest LLVM (from source) installed using the default "sudo
make install", i.e. into /usr/local. Using cabal install --configure-option
--with-llvm-prefix=/usr/local doesn't change the result. LLVM is indeed
based in /usr/local. The binaries are in /usr/local/bin/, libLLVM*.a is in
/usr/local/lib, etc. Google just shows that this error has cropped up a
couple times before. I tried manually disabling the check in the configure
script but then generating code fails with massive run-time errors that look
like link problems.

I'm on an up-to-date Snow Leopard, using the latest llvm bindings from
darcs, cabal-install 0.8.0, cabal library, ghc 6.12.1, and LLVM from
svn. LLVM works fine from C++, at least. I worked through the Kaleidoscope
tutorial and a few hand-coded .ll files without a hitch.

Have you seen anything like this before? Any tips or things to try? I can't
think of what magic setting I'm missing.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20100409/1df83061/attachment.html

More information about the Haskell-Cafe mailing list