[Haskell-cafe] Hackage bug? Autobuild failure on literate source with ignored code blocks.

John Millikin jmillikin at gmail.com
Mon Sep 28 15:53:48 EDT 2009

In that case, I'll update my code and the wiki to use an alternative code style.

On Mon, Sep 28, 2009 at 09:21, Duncan Coutts
<duncan.coutts at googlemail.com> wrote:
> Your local Cabal version is older than the one Hackage is using and that
> older version lets haddock (ie ghc) do the pre-processing where as in
> the current version Cabal does the unlitting before running haddock.
> That explains the difference you observe.

Since Hackage is using an unstable development build of Cabal, I'd
like to force it to use a released version to prevent such an issue
from occurring again. I've added the following line to my .cabal file:

cabal-version: >= 1.6 && < 1.7

However, when testing with Cabal 1.7.3 (which is the version used by
Hackage), I am warned that:

Warning: dbus-core.cabal: This package requires Cabal version: >=1.6 && <1.7
Distribution quality errors:
This package requires Cabal version: >=1.6 && <1.7
Note: the public hackage server would reject this package.

Does this mean that it's impossible to require an earlier version of
Cabal in Hackage-published packages? If so, the use of a development
version of Cabal in the auto-build system seems unwise.

More information about the Haskell-Cafe mailing list