[Haskell-cafe] Can't install chp (confused by cabal yet again)

Michael Steele mikesteele81 at gmail.com
Mon Sep 14 15:05:14 EDT 2009

You got the original error because cabal chose to use base-3 when compiling
chp, and then identifiers found only in base-4 were referenced.
Download the cabal package, and edit chp.cabal so that it depends on base >=

On Sat, Jun 6, 2009 at 7:00 AM, Colin Paul Adams
<colin at colina.demon.co.uk>wrote:

> I tried a cabal install chp: It complained that base was hidden.
> So I unpacked the archive, and tried installing using runhaskell
> Setup configure/build/install. Now I get (from install):
> Setup: You need to re-run the 'configure' command. The version of Cabal
> being
> used has changed (was Cabal-, now Cabal-
> So I repeated the process and get the same message again.
> ghc version is 6.10.3
> Also:
> cabal --version
> cabal-install version 0.6.2
> using version of the Cabal library
> Where does this 1-6.0.3 come from (Ghc HEAD perhaps?)? What can I do
> about it?
> --
> Colin Adams
> Preston Lancashire
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20090914/ee9bc149/attachment.html

More information about the Haskell-Cafe mailing list