[Haskell-cafe] problems with HOC install from svn

John Velman velman at cox.net
Wed Sep 9 13:02:45 EDT 2009

I'm guessing the problem was with cabal's use of dlopen (see my inclusion
of error message below).  From some googling, the OS-X dlopen was redone by
apple at some time and from results I obtained, seems to require dylib
libraries unless (some things I don't understand).

It seems that some earlier versions of GHC could use dylibs, but not 6.10.

>From some similar sounding issues I found in the issues part of the HOC
site on code.google, I made a wild guess that using 

sudo runhaskell Setup.hs [options] 

might work.  It did.  I went all the way through the installation
instructions using this procedure wherever the README file said "cabal".
Everything compiled, linked, and installed in global locations.  Also
compiled and linked one of the examples this way, and it seems to work.

I'll submit an issue to the HOC site (if it will let me -- don't know about
permissions for issues on this site).

Thanks for your interest and help.

John Velman

On Tue, Sep 08, 2009 at 11:44:36PM -0400, Ross Mellgren wrote:
> I have binary-0.5 not binary-, but it doesn't have any dylibs. 
> Moreover, I was under the impression that GHC does not yet support shared 
> libraries like those, so I'm not sure why it would be looking for one. I 
> can't really speculate, maybe more of the build output might help?
> -Ross
> On Sep 8, 2009, at 10:54 PM, John Velman wrote:
>> Thanks.  Now I do have libHSbinary- in /usr/local/lib,
>> but apparently  not the dylib version.  Tomorrow I'll look further.
>> Perhaps there are some options to produce dylib libraries.  I've used
>> Haskell on Linux some time ago (but not Cabal), and have been Xcoding with
>> Objective C for a year or so now, but never tried this before.  I am
>> interested in HOC, but I've obviously got a lot to learn.
>> Thanks again,
>> John Velman
>> On Tue, Sep 08, 2009 at 08:35:54PM -0400, Ross Mellgren wrote:
>>> It sounds like it's looking for the binary package -- you should install 
>>> it
>>> using cabal, e.g.
>>> private (per-user) install:
>>> cabal update
>>> cabal install binary
>>> global (system-wide) install:
>>> sudo cabal update
>>> sudo cabal install --global binary
>>> -Ross
>>> On Sep 8, 2009, at 7:57 PM, John Velman wrote:
>>>> I'm unable to build HOC from the svn read-only checkout.  Here are some
>>>> details of what I'm doing.
>>>> I'm running OS X 10.5.8 on an intel iMac with Xcode is 3.1.3.
>>>> Haskel and Cabal are from the Haskel platform,
>>>> haskell-platform-2009.2.0.2-i386.dmg
>>>> I got Parsec 3.0 from Hackage.
>>>> I checked out HOC using the svn command at
>>>> http://code.google.com/p/hoc/source/checkout
>>>> and checked out revision 411.
>>>> Configure goes OK except for the complaint:
>>>> ----
>>>> Setup.hs:1:0:
>>>>   Warning: In the use of `defaultUserHooks'
>>>>            (imported from Distribution.Simple):
>>>>            Deprecated: "Use simpleUserHooks or autoconfUserHooks, unless
>>>> you need Cabal-1.2
>>>>            compatibility in which case you must stick with
>>>> defaultUserHooks"
>>>> ----
>>>> But when I try to build, I get, after a bunch of apparently successful
>>>> things:
>>>> -----------
>>>> Loading package binary- ... <command line>: can't load .so/.DLL
>>>> for: HSbinary- (dlopen(libHSbinary-, 9): image not
>>>> found)
>>>> -----------
>>>> I certainly can't find libHSbinary... of any version on my computer, 
>>>> dylib
>>>> or not.  Tried looking in the /Library/Frameworks/GHC.Framework stuff,
>>>> also
>>>> did a find . -iname "*libHS* and found libHSGLFW..., libHSparsec-3.0.0.
>>>> (also tried this in my home directory).
>>>> What is this, and how do I get it?
>>>> Best,
>>>> John Velman
>>>> _______________________________________________
>>>> Haskell-Cafe mailing list
>>>> Haskell-Cafe at haskell.org
>>>> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list