[Haskell-cafe] How do I fix this error message?

Michael Vanier mvanier42 at gmail.com
Fri Sep 4 17:03:47 EDT 2009

Hi everyone,

I ran into this error when recompiling some code I hadn't worked on in a 

    Could not find module `Control.Monad.Error':
      it was found in multiple packages: monads-fd- mtl-

I gather that monads-fd is supposed to be a replacement for mtl, but I 
have both of them (mtl from the normal GHC 6.10.4 install, monads-fd 
from cabal).  I don't really care which one I use, though mtl has been 
fine in the past.  In the past, I had to manually uninstall cabal 
packages that used incompatible libraries.  Is this still the case?



More information about the Haskell-Cafe mailing list