[Haskell-cafe] Snow Leopard, gtk2hs

Judah Jacobson judah.jacobson at gmail.com
Sat Oct 10 21:29:52 EDT 2009

On Tue, Oct 6, 2009 at 11:41 AM, Arne Dehli Halvorsen
<arne.d.h at gmail.com> wrote:
> This may be a little off-topic, but if someone could help me, I'd be
> grateful.
> I am trying to get to a working gtk2hs environment in MacOSX Snow Leopard
> I have a Macbook Pro 2.1 with Snow Leopard.
> While I had Leopard, I had the Haskell Platform installed, and it worked
> fine.
> I also had the MacPorts edition of gtk, and compiled gtk2hs by hand.
> After I got Snow Leopard, I installed the Haskell Platform. I have made the
> necessary changes to make it compile (flags to ghc), and it compiles normal
> programs.
> I installed the standalone version of the GTK+ platform, and then tried to
> compile gtk2hs from /gtk2hs .
> ./configure works, but make results in this:
> [snip]
> /var/folders/G8/G8LY9MSBEGuyatB+JjSWq++++TI/-Tmp-/ghc4162_0/ghc4162_0.split__2870.s:35:0:
>     invalid character '_' in mnemonic
> /var/folders/G8/G8LY9MSBEGuyatB+JjSWq++++TI/-Tmp-/ghc4162_0/ghc4162_0.split__2870.s:953:0:
>     FATAL:Symbol L_gtk_misc_get_type$stub already defined.
> make[1]: *** [gtk/Graphics/UI/Gtk/Types.o] Error 1
> make: *** [all] Error 2
> I also have gtk installed via macports recently, but I am not sure whether
> this makes a difference.
> I don't think there is any point currently in trying to go MacPorts all the
> way, and install ghc+gtk2hs via MacPorts.
> Does anyone have a recipe for getting ghc + gtk2hs + gtk working on MacOSX
> Snow Leopard?
> Best regards,
> Arne D Halvorsen

I was able to get gtk2hs working with ghc-6.10.3 (after patching the
/usr/bin scripts with -m32) by following the steps from


with one change:  call configure for gtk2hs as

./configure --disable-split-objs --disable-gio

Hope that helps,

More information about the Haskell-Cafe mailing list