[Haskell-cafe] Wiki software?
gwern0 at gmail.com
Sat Nov 21 11:38:14 EST 2009
On Sat, Nov 21, 2009 at 11:14 AM, Vladimir Ivanov
<vladimir.v.ivanov at gmail.com> wrote:
> I decided to give orchid a try, but failed to install the latest
> version (0.0.8) using cabal.
> The reason is that one of the dependencies (filestore) depends on
> parsec-2.0.* and orchid requires parsec3. I installed filestore-0.2
> separately, but nothing changed.
> $ cabal install orchid
> Resolving dependencies...
> cabal: cannot configure filestore-0.2. It requires parsec ==2.*
> For the dependency on parsec ==2.* there are these packages: parsec-2.0,
> parsec-184.108.40.206 and parsec-220.127.116.11. However none of them are available.
> parsec-2.0 was excluded because orchid-0.0.8 requires parsec ==3.0.*
> parsec-18.104.22.168 was excluded because orchid-0.0.8 requires parsec ==3.0.*
> parsec-22.214.171.124 was excluded because orchid-0.0.8 requires parsec ==3.0.*
> $ ghc-pkg list filestore
> filestore-0.2, filestore-0.3.2, filestore-0.3.3
> $ ghc-pkg list parsec
> parsec-126.96.36.199, parsec-3.0.0
> $ cabal --version
> cabal-install version 0.6.2
> using version 188.8.131.52 of the Cabal library
> Have you seen this before?
> I hope I overlooked something trivial... =)
> -- vi
Apparently you can build filestore with parsec-3 if you want.
Data/FileStore/Git.hs doesn't seem to use any of the functionality
that changed between 2 & 3. I swapped the dep:
hunk ./filestore.cabal 35
- parsec >= 2 && < 3, process, time,
datetime, regex-posix, xml, split, Diff
+ parsec >= 3, process, time, datetime,
regex-posix, xml, split, Diff
Configured, noticing what parsec was being used:
Dependency parsec >=3: using parsec-3.0.0
Built & installed successfully.
More information about the Haskell-Cafe