[Haskell-cafe] Cabal upload issue

Jeremy O'Donoghue jeremy.odonoghue at gmail.com
Thu Nov 12 09:29:33 EST 2009

Hi all,

I'm in the process of trying update the revisions of wx (part of
wxHaskell) on hackage.

I'm getting an error I find slightly surprising:

"400 Error in upload
The dependency 'build-depends: base' does not specify an upper bound
on the version number. Each major release of the 'base' package
changes the API in various ways and most packages will need some
changes to compile with it. The recommended practise is to specify an
upper bound on the version of the 'base' package. This ensures your
package will continue to build when a new major version of the 'base'
package is released. If you are not sure what upper bound to use then
use the next  major version. For example if you have tested your
package with 'base' version 2 and 3 then use 'build-depends: base >= 2
&& < 4'."

In this case, we have the following in wx.cabal

    if flag(splitBase)
        build-depends: base >= 3, wxcore >=, stm
        build-depends: base <  3, wxcore >=, stm

Is this a bug, or am I doing something stupid?

I should point out that this builds perfectly on my machine.


More information about the Haskell-Cafe mailing list