[Haskell-cafe] ANNOUNCE: vacuum-cairo: a cairo frontend to vacuum for live Haskell data visualization

Sebastian Fischer sebf at informatik.uni-kiel.de
Tue Mar 31 13:52:26 EDT 2009

On Mar 31, 2009, at 7:15 PM, Brandon S. Allbery KF8NH wrote:

>> cabal: cannot configure vacuum-cairo-0.3.1. It requires svgcairo -any
>> There is no available version of svgcairo that satisfies -any
> This is looking for the Haskell svgcairo package, in other words the  
> Haskell binding for the libsvg-cairo package that you have installed.

Where do I get this? (It's not on Hackage) Is it usually installed  
with Gtk2Hs?

On Mar 31, 2009, at 7:36 PM, Manuel M T Chakravarty wrote:

> The native GTK+ framework is a port of GTK+ to the native Mac GUI  
> and dead easy to install (it has a binary installer).   
> Unfortunately, it lacks many of GTK+'s optional components (most  
> notably libglade).  It is however in beta right now, so we can only  
> hope that there will be more of the optional components in the final  
> version.

So, I assume, there's no way to get the Haskell bindings for libsvg- 
cairo when using the native GTK+ framework? What a pity!


More information about the Haskell-Cafe mailing list