[Haskell-cafe] putting SOE 'on the library path'

Michael Mossey mpm at alumni.caltech.edu
Sat Mar 28 13:46:39 EDT 2009

I tried the -v, but I seem to have fixed my problem. It's working now. I 
don't know what I changed. Maybe I typed the paths wrong before. Anyway, 
it does seem to accept (on Windows) paths with backslashes and it 
accepts spaces in the path if you put quotes around it.

I'm still interested, though, in how one "installs" packages or modules 
so they don't need to be on the path specified by -i. I notice there is 
a file called 'package.conf', which seems related to this.

Martijn van Steenbergen wrote:
> Michael Mossey wrote:
>> I tried using the -i options to ghc and ghci, but to no avail. It 
>> wasn't clear on Windows in what form -i takes its arguments: 
>> backslashes as usual for Windows, forward slashes perhaps? How about 
>> paths with spaces in them? Does it need quotes around the filename? I 
>> tried all combinations. ghc never gave an error indicating there was 
>> something wrong with what I typed. It happily accepted all forms of 
>> -i. But it never found the libraries.
> Have you tried starting GHC with -v to see what paths it looks in?
> Martijn.

More information about the Haskell-Cafe mailing list