[Haskell-cafe] wxHaskell

Tsunkiet Man temp.tsun at gmail.com
Fri Mar 27 14:35:05 EDT 2009


I've just installed wxHaskell as follow:

- Download wxHaskell from the following page:
http://haskell.org/haskellwiki/WxHaskell/Download and downloaded the binairy
version for Windows XP.
- Registered using the batch file provided.

Now I have this small program from my education page that I want to run just
to make sure my installation is correct. (
http://www.cs.uu.nl/wiki/pub/FP/Practicum/Balls.hs) I've also got Helium
(2003) and winHugs (sept 2006) (I'm so sorry for using the old versions, but
I just can't find new versions) My GHC compiler is version: GHC 6.10.1 and
my wxHaskell is named like: wxhaskell-bin-msw2.8.9-ghc6.10.1-0.11.0-0.zip.
(If you need more information just contact me)

Now my error message in winHugs is: And if

ERROR file:.\Balls.hs - Can't find imported module "Graphics.UI.WX"

And if I run that in Helium I get some error message that the . in
"Graphics.UI.WX" is unexpected. (Which means by my views that it didn't
import wxHaskell.)

And if I run it in ghci it compiles perfect. So I thought let's type in
"main" to start it in a interpreter. So I get the following:
http://img10.imageshack.us/img10/5118/testzrs.jpg. I don't think that
program is running correctly. Can someone point out what went wrong or what
I am doing wrong?

And some small question, do I always have to compile those programs in order
for it to run correctly?

Thanks for your time and effort!

Tsunkiet Man
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20090327/b7fcf005/attachment.htm

More information about the Haskell-Cafe mailing list