[Haskell-cafe] ANNOUNCE: Extensible and Modular Generics for theMasses: emgm-0.3

Claus Reinke claus.reinke at talk21.com
Tue Mar 3 08:19:15 EST 2009

>Due to a problem with the template-haskell package and Cabal, you
>cannot cabal-install the emgm package with GHC 6.8. However, take
>heart! EMGM works very well with GHC 6.8. You merely have to download
>the tar.gz package from Hackage yourself, build it, and install it.

I thought I had seen you mention a workaround for that issue, but
if not, perhaps you might want to add your experience to

    Cabal should support Cabal-version-dependent Setup.hs

There's a sketched hack-around at the end, using Setup.hs only 
to call to separate Setup-version.hs files, to circumvent Cabal API
instabilities. Not nice, but perhaps better than to bypass Cabal
alltogether? One would also have to pass parameters, and the
Process API has changed in the meantime.., which I why I still
think Cabal itself should simply be able to pick cabal-versioned 
configuration and setup files, if they exist.


More information about the Haskell-Cafe mailing list