[Haskell-cafe] Can't install mkcabal because of pcre-lite

Colin Paul Adams colin at colina.demon.co.uk
Sun Mar 1 03:42:26 EST 2009

cabal: Error: some packages failed to install:
mkcabal-0.4.2 depends on pcre-light-0.3.1 which failed to install.
pcre-light-0.3.1 failed during the configure step. The exception was:
exit: ExitFailure 1

Downloading pcre-light-0.3.1...
Configuring pcre-light-0.3.1...
cabal: Missing dependency on a foreign library:
* Missing C library: pcre
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.

I'm on fedora 10.

I have package pcre installed. But yum install pcre-dev so no such

Anyone know the anser?
Colin Adams
Preston Lancashire

More information about the Haskell-Cafe mailing list