[Haskell-cafe] Cabal fun [Half-integer]

Jason Dagit dagit at codersbase.com
Mon Jun 29 15:12:50 EDT 2009

On Mon, Jun 29, 2009 at 11:57 AM, Andrew Coppin <andrewcoppin at btinternet.com
> wrote:

> Andrew Coppin wrote:
>> Indeed. I've heard a few people claim that cabal-install is the best thing
>> since sliced bread, but I've never touched it. I don't even know where to
>> get it. (Presumably this will become fairly obvious once I go look for
>> it...)
> Fortunately, it turns out that a trivial Google search is all that is
> required to locate cabal-install. (Assuming you already know it exists.)
> Unfortunately I got as far as actually downloading the sources from Hackage
> before discovering that on Windows you actually need to download the
> pre-build binary. (Couldn't you mention this on the Hackage download page?)
> Also fortunately, it appears to be pretty trivial to operate cabal-install.
> I didn't bother reading any instructions, just cabal --help. (Not sure why
> it needs to download the package list from Hackage - or where it puts it.
> But I'm sure there's a good reason.)
> Rather less fortunately, it still doesn't actually fix my problem:
> E:\Haskell\AOC-HalfInteger>cabal configure
> Resolving dependencies...
> Configuring AOC-HalfInteger-1.0...
> E:\Haskell\AOC-HalfInteger>cabal sdist
> Building source dist for AOC-HalfInteger-1.0...
> Preprocessing library AOC-HalfInteger-1.0...
> Source tarball created: dist\AOC-HalfInteger-1.0.tar.gz
> cabal: dist\src\sdist.1288\AOC-HalfInteger-1.0\Data\HalfInteger.hs:
> removeFile: permission denied (Permission denied)
> I have no idea what the hell it's upset about now... I've now been trying
> to create this damned tarball since 5PM yesterday, and I still haven't
> managed it. At this point I'm losing the will to continue with this crazy
> project. Clearly this is way too much effort to expend just to upload 50
> lines of code.

I can't say for certain, but just reading the output it looks like it
created a tarball in a temporary folder (that worked) and then when it tried
to clean it up it failed.  Sounds like a bug report is in order.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20090629/fde0dbb9/attachment-0001.html

More information about the Haskell-Cafe mailing list