[Haskell-cafe] How to determine if a FilePath is a directory name or regular file?

Deniz Dogan deniz.a.m.dogan at gmail.com
Mon Jun 22 02:53:05 EDT 2009

2009/6/22 Colin Paul Adams <colin at colina.demon.co.uk>:
>>>>>> "Judah" == Judah Jacobson <judah.jacobson at gmail.com> writes:
>    Judah> On Sun, Jun 21, 2009 at 11:12 PM, Colin Paul
>    Judah> Adams<colin at colina.demon.co.uk> wrote:
>    >> I've been hoogling like bad to try to determine if a function
>    >> like this exists.
>    >>
>    >> getDirectoryContents returns sub-directories as well as file
>    >> names. I want only the latter, so I'm looking for a suitable
>    >> filter.
>    Judah> Use System.Directory.doesDirectoryExist/doesFileExist.
> Thanks.
> it seems it's time i went to the optician again.

I'm not surprised that anyone would make the mistake. I think that the
two functions should be named "isDirectory" and "isFile", but it seems
that "isDirectory" was already taken by another function in
System.Directory, which is quite unfortunate. "does" goes against the
intuition one gets from pretty much everything else in Haskell, where
"is" seems to be the convention. In fact, Hoogle only knows about
three functions which start with "does".

Deniz Dogan

More information about the Haskell-Cafe mailing list