[Haskell-cafe] Re: [Haskell] ANNOUNCE: testrunner-0.9

Rodney Price rodprice at raytheon.com
Wed Jun 10 18:14:53 EDT 2009

When I run Example.lhs for test-framework I get 


in the test results, just as you show on your web page.  If I run
Example.lhs under ghci rather than compiled, I find the [0] [1] mingled
with the test results in random ways.  This leads me to believe that
whatever is printing out [0] [1] is running is a separate thread.

Does this [0] [1] have any meaning?  If not, how do I get rid of it?


On Mon, 8 Jun 2009 19:07:52 +0100
Max Bolingbroke <batterseapower at hotmail.com> wrote:

> 2009/6/8 Reinier Lamers <tux_rocker at reinier.de>:
> > I checked out testpack and that did not meet my requirements. I
> > don't know if I considered test-framework. If I did, it may be that
> > I was turned off by the fact that the 'home page' link on cabal
> > just goes to a web presentation of the source tree on github.
> Reinier,
> You are quite right that this is a weakness. I've been meaning to put
> a site together for a while, and your comment gave me the impetus to
> do it:
> http://batterseapower.github.com/test-framework/
> That's much friendlier!
> All the best,
> Max
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe
> The following line is added for your protection and will be used for
> analysis if this message is reported as spam:
> (Raytheon Analysis: IP=;
> e-from=haskell-cafe-bounces at haskell.org;
> from=batterseapower at hotmail.com; date=Jun 8, 2009 6:08:07 PM;
> subject=[Haskell-cafe] Re: [Haskell] ANNOUNCE: testrunner-0.9)

More information about the Haskell-Cafe mailing list