[Haskell-cafe] ANN: HDBC v2.0 now available

John Goerzen jgoerzen at complete.org
Fri Jan 30 19:31:00 EST 2009

On Sat, Jan 31, 2009 at 12:52:02AM +0100, Krzysztof Skrz??tnicki wrote:
> > I got the same error: Windows XP, GHC 6.10.1.
> > For some reason imported Control.Exception module appears to be 6.8.*
> > version.
> >
> I found a (temporary) fix: change dependancy in .cabal file to state "base
> >= 4". Otherwise cabal-install selects base-3 which is the cause of the
> problems.

Thanks for the hint for folks.

Why would cabal-install select a different base than running Setup

I can't hard-code base >= 4 into .cabal because that would break for
GHC 6.8 users.  I have CPP code that selects what to compile based on
GHC version.

-- John

More information about the Haskell-Cafe mailing list