[Haskell-cafe] Dependencies conflict

Martijn van Steenbergen martijn at van.steenbergen.nl
Wed Jan 28 12:22:16 EST 2009


$ cabal install category-extras
Resolving dependencies...
cabal: dependencies conflict: ghc-6.10.1 requires process == however
process- was excluded because ghc-6.10.1 requires process ==

What does this message mean? It makes little sense to me -- ghc-6.10.1 
requires both process == and process ==

And, more importantly, how do I solve this?

Below is my output of ghc-pkg list.

Thanks much,


$ ghc-pkg list
     Cabal-, HUnit-, QuickCheck-, array-,
     base-, base-, bytestring-, containers-,
     directory-, (dph-base-0.3), (dph-par-0.3),
     (dph-prim-interface-0.3), (dph-prim-par-0.3), (dph-prim-seq-0.3),
     (dph-seq-0.3), editline-, filepath-, (ghc-6.10.1),
     ghc-prim-, haddock-2.3.0, haskell-src-,
     haskell98-, hpc-, html-, integer-,
     mtl-, network-, old-locale-, old-time-,
     packedstring-, parallel-, parsec-,
     pretty-, process-, random-,
     regex-base-, regex-compat-, regex-posix-,
     rts-1.0, stm-, syb-, template-haskell-,
     time-, unix-, xhtml-3000.2.0.1
     HTTP-3001.1.5, binary-0.4.4, brainfuck-0.1, cpphs-1.6,
     data-accessor-0.1.4, data-accessor-template-0.1.4,
     extensible-exceptions-, fgl-, ghc-paths-,
     haddock-2.4.1, haskeline-, haskell-src-exts-0.3.12,
     haskell-src-exts-0.4.4, haskell-src-exts-0.4.6,
     haskell-src-exts-0.4.8, haskell98-, hscurses-,
     iconv-, lambdabot-utils-4.2, oeis-0.2, parsec-3.0.0,
     process-, readline-, show-0.3.1, smallcheck-0.4,
     tagsoup-0.6, terminfo-0.3, uniplate-, unlambda-0.1,
     utf8-string-0.3.3, zlib-

More information about the Haskell-Cafe mailing list