[Haskell-cafe] Re: Improved documentation for Bool (Was: Comments from OCaml Hacker Brian Hurt)

Heinrich Apfelmus apfelmus at quantentunnel.de
Sun Jan 18 13:32:32 EST 2009

Sterling Clover wrote:
> This is a great effort, but the root of the problem isn't just poor
> documentation, but an insistence on some obscure name. How about
> renaming Bool to YesOrNoDataVariable? I think this would help novice
> programmers a great deal.
> It would also make the documentation flow much more naturally:
> The Bool type is the coproduct of the terminal object with itself.
> --huh?
> The YesOrNoDataVariable is the coproduct of the terminal object with
> itself.
> --Oh! Of course!

I'm sorry, but I don't get neither Bool nor YesOrNoDataVariable, it's
too confusing for newcomers. Can we please name it to


that's much more intuitive.

Also, the wikipedia page


is extremely unhelpful. Not that the wikipedia page for Bool which links to


is any better. The introduction goes to great lengths to note that

  For instance the ISO SQL:1999 standard defined a Boolean data type
  for SQL which could hold three possible values: true, false, unknown
  (SQL null is treated as equivalent to the unknown truth value, but
  only for the Boolean data type)

What is SQL, do they mean the SesQuiLinear forms that I'm familiar with?
But what does it have to do with TerminalObjectCoSquared? I'm confused.



More information about the Haskell-Cafe mailing list