[Haskell-cafe] Re: ANN: hledger 0.3 released

Sebastian Sylvan sebastian.sylvan at gmail.com
Sun Jan 18 13:12:46 EST 2009

Yeah looks like it depends on unix. Also, looks like the terminfo package 
isn't cross-platform either.

Perhaps we need a better tool to mark packages which are platform-specific, 
so people don't accidentally use them, especially if they're a few levels 
away in the dependency graph.

From: "Simon Michael" <simon at joyful.com>
Sent: Sunday, January 18, 2009 6:08 PM
To: "Sebastian Sylvan" <sebastian.sylvan at gmail.com>
Cc: <hledger at googlegroups.com>; <haskell-cafe at haskell.org>
Subject: Re: ANN: hledger 0.3 released

> On 1/18/09 9:39 AM, Sebastian Sylvan wrote:
>> I was interested in actually using this "for real", but unfortunately it 
>> seems like you have a dependency on the unix package. Would it be 
>> possible to use something portable (specifically to windows) instead?
> Darn, thanks for the heads up. I guess we need to make the vty requirement 
> (and ui command) optional. (I thought vty was cross-platform. :/)

More information about the Haskell-Cafe mailing list