[Haskell-cafe] Re: [Haskell] HaskellWiki Upgrade Aborted

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Sun Jan 11 09:13:19 EST 2009

On Sat, 2009-01-10 at 19:02 -0800, Ashley Yakeley wrote:
> I have given up attempting to upgrade HaskellWiki, and resumed the 
> site's previous normal operation.
> I wrote:
> > I will also need up upgrade both PHP and MySQL.
> It turns out it would be hard to upgrade MySQL, as various things depend 
> on the old version:

For example the gtk2hs website is using mysql and php too. I think we'd
need to upgrade that to have it work with mysql-5. Perhaps gtk2hs should
move to projects.haskell.org.

> $ sudo rpm -U MySQL-server-community-5.1.30-0.rhel3.i386.rpm
> warning: MySQL-server-community-5.1.30-0.rhel3.i386.rpm: V3 DSA 
> signature: NOKEY, key ID 5072e1f5
> error: Failed dependencies:
> 	libmysqlclient.so.10 is needed by (installed) mod_auth_mysql-20030510-2.ent
> 	libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.1021-4.EL3
> 	libmysqlclient.so.10 is needed by (installed) php-mysql-4.3.2-48.ent
> I don't know what mod_auth_mysql and perl-DBD-MySQL are being used for, 
> so I don't believe I can upgrade them safely.
> The machine is running RHEL AS 3 update 9 with Linux 2.4.21.

We really need to upgrade the whole thing. Not an easy job given the
range of stuff being run on there by lots of different people.


More information about the Haskell-Cafe mailing list