[Haskell-cafe] Status of Haskell under OsX

Thomas Davie tom.davie at gmail.com
Fri Feb 27 05:33:29 EST 2009

On 27 Feb 2009, at 11:21, Arne Dehli Halvorsen wrote:

> Thomas Davie wrote:
>> For me, this worked:
>> sudo port install ghc
>> sudo port install gtk2
>> sudo port install cairomm
>> curl http://downloads.sourceforge.net/gtk2hs/gtk2hs-0.10.0.tar.gz >  
>> gtk2hs-0.10.0.tar.gz
>> tar xvfz gtk2hs-0.10.0.tar.gz
>> normal install stuff here.
> It worked!
> I had to throw out gtk2, which was present in an incompatible version.
> Then I did make/make install, and tried compiling a few apps in the  
> demo catalog.
> Most of them show up, but with these errors:
> Xlib:  extension "RANDR" missing on display "/tmp/launch-UoNAfJ/:0".
> Xlib:  extension "Generic Event Extension" missing on display "/tmp/ 
> launch-UoNAfJ/:0".
Yep, I see these errors too – even after sudo port install randr.

> Testing out the demos, it seems it can't find
> Graphics.UI.Gtk.Glade,
> Graphics.Rendering.OpenGL
> System.Gnome.GConf
> System.Gnome.VFS
> Media.Streaming.GStreamer
> Graphics.UI.Gtk.MozEmbed
> Graphics.UI.Gtk.SourceView
> Graphics.Rendering.Cairo.SVG
Perhaps the demos are out of date?  Graphics.Rendering.OpenGL is found  
in the OpenGL package, and System.Gnome looks unlikely to work on OS X.


More information about the Haskell-Cafe mailing list