[Haskell-cafe] Re: How outdated is Hugs?

Simon Marlow marlowsd at gmail.com
Wed Feb 11 10:33:56 EST 2009

Conrad Meyer wrote:
> On Tuesday 10 February 2009 06:41:54 am Simon Marlow wrote:
>> John Goerzen wrote:
>>> Just to close -- I will point out that ghci doesn't work on many
>>> platforms that Hugs does (though ghc does).  Hugs is the only
>>> interpreter on some of these platforms.
>> I didn't see anyone follow up to this so I'll just mention that nowadays
>> GHCi works wherever GHC works, since 6.10.1.  Actually I think most
>> platforms worked with 6.8.1, but 6.10.1 added libffi which meant that GHCi
>> also gets working FFI support on any platform supported by libffi, which is
>> most of them.
>> Cheers,
>> 	Simon
> Counterexample: GHC 6.10.1 works on linux/ppc, GHCi 6.10.1 does not. (6.8.3 
> worked, though.)

I presume you're referring to this bug:


So I should really say that /in theory/ there's no reason why GHCi 
shouldn't work if GHC works, platform-specific bugs notwithstanding.  As 
Ian said in a comment on that bug, I expect that an unregisterised build 
would work fine.

We could do with a Linux/PPC expert to help improve GHC support on that 


More information about the Haskell-Cafe mailing list