[Haskell-cafe] ANN: HDBC v2.0 now available

Niklas Broberg niklas.broberg at gmail.com
Sun Feb 1 09:56:19 EST 2009

> So in the next cabal-install release (which should be pretty soon now)
> configure will do the same thing and pick base 3 unless you specify
> build-depends base >= 4.

... and so there will never be any incentive for these many packages
to migrate to base-4, which also has consequences for packages that do
want to use base-4, but also want to depend on such packages. And so
base-3 will live on in eternity, and there was never any point in
doing that new base release at all.

I really really think this is the wrong way to go. Occasional
destruction is desperately needed for progress, else things will
invariably stagnate.

I would suggest as a less stagnating approach to issue a warning/hint
when a package with no explicit version dependency for base fails to
build. The hint could suggest to the user trying to build the package
that they can use 'cabal instal --package=base-3'.



More information about the Haskell-Cafe mailing list