[Haskell-cafe] Cabal

Duncan Coutts duncan.coutts at googlemail.com
Fri Dec 18 12:52:35 EST 2009

On Thu, 2009-12-17 at 18:08 +0000, Nils Anders Danielsson wrote:

> I was hoping that I could make use of this feature now:
>   $ cabal --version
>   cabal-install version 0.7.5
>   using version of the Cabal library
> However, when I try to use it I get the following error:

So there's two bugs.

One is that cabal-install doesn't know about this new stuff. Stephen
Blackheath has a patch for this but it's not yet been reviewed and

The other is that the feature currently fails with ghc-6.12 but we
didn't notice in time to fix it before the release.

> Is this feature supposed to work now, or has it been postponed?

It works with 6.10 if you're not using cabal-install.

Both issues will be addressed in future releases in the new stable


More information about the Haskell-Cafe mailing list