[Haskell-cafe] lhs2tex, Haskell Platform and cygwin

Jacques Carette carette at mcmaster.ca
Thu Dec 17 12:29:21 EST 2009

Stephen Tetley wrote:
> Hi Jacques
> Does it install properly by the runhaskell Setup.hs configure / build
> / install? I re-installed it this way a couple of weeks ago and it
> never mentioned mktexlsr.
No, it doesn't.  I first run into issues with exceptions-related issues 
(as you did), which I solved via
runghc Setup configure --constraint="base<4"

But the install still failed on mktexlsr.  So I tried
runghc Setup configure --constraint="base<4" 
runghc Setup build
runghc Setup install

but now I get a new error related to mktexlsr, namely
$ runghc Setup install
Installing executable(s) in C:\Program Files (x86)\Haskell\bin
Setup: \cygwin\bin\mktexlsr: runGenProcess: invalid argument (Exec 
format error)

mktexlsr is a /bin/sh script, so it's quite natural that an Exec on that 
would fail.  So I'm still stuck.

Thanks for the dos2unix pointer, that would have taken quite a while to 
figure out.


More information about the Haskell-Cafe mailing list