[Haskell-cafe] HP + Gtk2hs?

Andrew Coppin andrewcoppin at btinternet.com
Sat Dec 5 13:55:24 EST 2009

M Xyz wrote:
>     - Apart from HP providing GHC 6.10.4 while Gtk2hs currently
>     requires 6.10.3, it appears that the Gtk2hs installer package
>     doesn't like GHC being installed in a path with spaces. Apparently
>     Gtk2hs has a bug tracker. (I only just discovered this, so perhaps
>     it needs to be more prominent?) Somebody pointed out this bug 6
>     months ago. Somebody else posted a potential fix a month ago.
>     There is no visible activity from the developers. (I emphasize
>     "visible". Maybe they've seen this and they're working on it, but
>     there's no visible indication of activity.)
> Thank you so much for this post. I tried to install Gtk2hs yesterday 
> to play with
> its Cairo bindings and I hit the "Setup found what appears to be a 
> non-working installation of GHC" brickwall. I found a closed ticket 
> about this problem: http://hackage.haskell.org/trac/gtk2hs/ticket/1117
> I posted this issue on the Gtk2hs-devel mailing list and got a 
> response today:
> http://sourceforge.net/mailarchive/forum.php?thread_name=EF0EE62B-259C-4F62-9BF2-65FA1F01949E%40di.ens.fr&forum_name=gtk2hs-devel
> I don't think I have the will to uninstall the Haskell Platform and 
> everything I've set up just to install in a path with no spaces. :)
My information is from here:


In case it makes any difference to you. :-)

More information about the Haskell-Cafe mailing list