[Haskell-cafe] gbp sign showing as unknown character by GHC

Alexander Dunlap alexander.dunlap at gmail.com
Wed Aug 19 14:16:26 EDT 2009

On Wed, Aug 19, 2009 at 11:08 AM, Iain Barnett<iainspeed at gmail.com> wrote:
> 2009/8/19 David Leimbach <leimy2k at gmail.com>
>> Interesting... GHCI bug?  Didn't the readline dependency go away not too
>> long ago?  Could it be related?
> I just tried this
> Prelude> putStrLn "\£"
> ghc: panic! (the 'impossible' happened)
>   (GHC version 6.10.4 for i386-unknown-linux):
> charType: '\163'
> Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
> So perhaps I should put in a bug report, as that shouldn't happen (it
> doesn't with some other characters I tried), unless anyone has a different
> idea? I'm running Arch Linux with xmonad and using roxterm, so perhaps it's
> something to do with my setup?
> Iain
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

I can reproduce the panic on both urxvt and uxterm.

On urxvt, GHCi works correctly with putStrLn "£". On uxterm, it just
prints a blank space.

I can type the GBP sign into both terminals.

Could it be a terminfo problem of some sort? It seems suspicious that
there is a difference between terminals.


More information about the Haskell-Cafe mailing list