[Haskell-cafe] Problem with installing phooey

Daryoush Mehrtash dmehrtash at gmail.com
Mon Apr 27 22:26:37 EDT 2009

When I try to install Phooey I get the following error:

cabal  install --constraint="Stream == 0.3" phooey
Resolving dependencies...
[1 of 1] Compiling Main             (
/tmp/phooey-2.016943/phooey-2.0/dist/setup/Main.o )
Linking /tmp/phooey-2.016943/phooey-2.0/dist/setup/setup ...
Configuring phooey-2.0...
Warning: No 'build-type' specified. If you do not need a custom Setup.hs or
./configure script then use 'build-type: Simple'.
Preprocessing library phooey-2.0...
Building phooey-2.0...

    Could not find module `Data.Reactive':
      Use -v to see a list of the files searched for.

It seems that the current version of reactive (0.10.5) no longer has
Data.Reactive module (it seem to have been removed since 0.5 version of the

Does Phooey really need 0.5 version of the reactive or is there a problem in
my installation?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20090427/7e33ee91/attachment.htm

More information about the Haskell-Cafe mailing list