[Haskell-cafe] replicateM should be called mreplicate?

Luke Palmer lrpalmer at gmail.com
Mon Apr 6 13:46:17 EDT 2009

On Mon, Apr 6, 2009 at 11:42 AM, David Menendez <dave at zednenem.com> wrote:

> Of course, this suggests that mfix should be fixM, so perhaps a better
> distinction is that mplus and mfix need to be defined per-monad,
> whereas filterM and replicateM are generic.

Don't you think that is an incidental distinction, not an essential one?  It
would be like naming our favorite operations mbind and joinM, just because
of the way we happened to write the monad class.


> --
> Dave Menendez <dave at zednenem.com>
> <http://www.eyrie.org/~zednenem/ <http://www.eyrie.org/%7Ezednenem/>>
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20090406/a377ffc2/attachment.htm

More information about the Haskell-Cafe mailing list