[Haskell-cafe] Missing dependency?

Lyle Kopnicky lists at qseep.net
Thu Apr 2 19:13:02 EDT 2009

Hi folks,

Since the time package is not included in ghc-6.10.2, I installed it via
cabal. Then I tried to configure my project, and it says that the dependency
is missing. Mysterious. Can anyone explain?

lwk at lwk-desktop:~/devel/vintage-basic$ ghc-pkg list
    Cabal-, HUnit-, QuickCheck-, array-,
    base-, base-, bytestring-, containers-,
    directory-, (dph-base-0.3), (dph-par-0.3),
    (dph-prim-interface-0.3), (dph-prim-par-0.3), (dph-prim-seq-0.3),
    (dph-seq-0.3), editline-, filepath-, (ghc-6.10.2),
    ghc-prim-, haddock-2.4.2, haskell-src-,
    haskell98-, hpc-, html-, integer-,
    mtl-, network-2.2.1, old-locale-, old-time-,
    packedstring-, parallel-, parsec-,
    pretty-, process-, random-,
    regex-base-, regex-compat-, regex-posix-,
    rts-1.0, stm-, syb-, template-haskell-,
    unix-, xhtml-3000.2.0.1
    HTTP-4000.0.4, time-, zlib-
lwk at lwk-desktop:~/devel/vintage-basic$ runhaskell Setup.hs configure
Configuring vintage-basic-1.0.1...
Setup.hs: At least the following dependencies are missing:
time >=1.1
lwk at lwk-desktop:~/devel/vintage-basic$

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20090402/1d0c4ded/attachment.htm

More information about the Haskell-Cafe mailing list