[Haskell-cafe] Updated formlets sample?

Martin Huschenbett huschi at gmx.org
Sun Sep 21 15:11:22 EDT 2008

Hi Chris,

thanks for the updated example. Compiling works now. But when I try to 
run it I alway get error messages like

  ["input0 is not in the data","input1 is not in the data"]



Chris Eidhof schrieb:
> Hey Martin,
> On 19 sep 2008, at 04:14, Martin Huschenbett wrote:
>> I found a blog post concerning formlets [1] in the web. Since looks 
>> very interesting I tried to compile the sample code with recent 
>> versions of HAppS and formlets from hackage. But this didn't work as 
>> the API of formlets has changed since this post.
>> I tried to adopt the code to the new API but I was unable to finish 
>> this since there is a new monadic context I don't know to handle in 
>> the right way.
>> So my question is, is there an updated version of this sample code in 
>> the web or has anybody tried to adopt it and can send me the results?
> Yes, I'm sorry for that. The API is still very immature and due to 
> changes, that's also why it hasn't been officially announced yet. I've 
> just put an updated example at http://hpaste.org/10568, hope that'll 
> work for you. I guess we should build a small homepage / wikipage that 
> always has an up-to-date example.
> -chris

More information about the Haskell-Cafe mailing list