[Haskell-cafe] Re: GHC trouble on Leopard

Miguel Vilaca jmvilaca at di.uminho.pt
Wed Sep 17 08:36:55 EDT 2008

Hi Manuel,

After your tip, I check the file, it permissions and it content, and  
find that this specific file looks for perl in an existing place; this  
is a fresh Leopard and I just installed a few things using binaries.

It seems GHC expects perl to be installed through macPorts or Fink and  
i have neither of them.

Just changing the first line of the file
solves the problem.

Thanks for the help.

Miguel Vilaça

Em 2008/09/17, às 05:51, Manuel M T Chakravarty escreveu:

> Miguel,
>> I tried to compile some code on Mac Os X (Intel) Leopard.
>> I have GHC 6.8.3 installed - the installer from GHC webpage  
>> (GHC-6.8.3-i386.pkg).
>> But when I run make I get this error
>> ghc-6.8.3: could not execute: /Library/Frameworks/GHC.framework/ 
>> Versions/608/usr/lib/ghc-6.8.3/ghc-asm
> This is not a common problem.  I suspect that either your  
> installation somehow got corrupt or you somehow changed your Perl  
> installation.  (The file in question is a Perl script.)
> Manuel

More information about the Haskell-Cafe mailing list