[Haskell-cafe] cabal-install question

Ken98 sellerk01 at yahoo.com
Tue Oct 21 17:37:23 EDT 2008

Hello, I recently started using cabal-install to install packages. However,
ran into a problem today trying to install ftphs where the current HUnit
dependency required base (==4). I'm using ghc-6.8.2 on ubuntu. 

To get around this, I looked through previous versions of HUnit and found
that was the last to have a successful build with ghc-6.8. So, I
downloaded the tar.gz and did a runhaskell Setup.hs ... This worked and I
was able to complete the ftphs install. 

So my question is, could I have used cabal install to specify the specific
version of HUnit without having to do the manual

View this message in context: http://www.nabble.com/cabal-install-question-tp20098091p20098091.html
Sent from the Haskell - Haskell-Cafe mailing list archive at Nabble.com.

More information about the Haskell-Cafe mailing list