[Haskell-cafe] Congrats. to wxHaskell

shelarcy shelarcy at gmail.com
Tue Oct 14 05:54:45 EDT 2008

Hi Henk-Jan,

On Tue, 14 Oct 2008 07:53:57 +0900, Henk-Jan van Tuyl <hjgtuyl at chello.nl> wrote:
> I downloaded wxWindows 2.8.9 and tried to build it with the supplied
> makefile as
> suggested in the installation manual (I have MinGW and MSSY installed):
> (snip)
> Trying to install wxHaskell:
>> cabal install --global wx
> [...]
> install: /usr/local/lib/wxcore.o
> install directory: /usr/local/lib/
> install: /usr/local/lib/wxcore.pkg
> cat config/wxcore.pkg | sed -e "s|\${wxhlibdir}|/usr/local/lib|" | ghc-pkg
> update -
> Reading package info from stdin ... done.
> ghc-pkg.exe: /usr/local/lib/imports doesn't exist or isn't a directory
> (use --force to override)
> "make": *** [wxcore-register] Error 1
> cabal: Error: some packages failed to install:
> wx-0.10.5 depends on wxcore-0.10.5 which failed to install.
> wxcore-0.10.5 failed during the final install step. The exception was:
> exit: ExitFailure 2

wxHaskell requires to use cygwin when building on Windows currently. 
Because Cabal doesn't support binary distribution yet. If you want to
build wxHaskell yourself on Windows, you must install cygwin.


And I'm finding where causes this problem now.

Best Regards,

shelarcy <shelarcy    hotmail.co.jp>

More information about the Haskell-Cafe mailing list