[Haskell-cafe] Congrats. to wxHaskell

Henk-Jan van Tuyl hjgtuyl at chello.nl
Mon Oct 13 18:53:57 EDT 2008

On Sun, 12 Oct 2008 03:45:17 +0200, Don Stewart <dons at galois.com> wrote:

> I just want to congratulate the wxHaskell team on their new release.
> With GHC 6.10 RC, cabal 1.6, and cabal-install 0.6, I was able to
> simply,
>     cabal install wxcore wx
> And it all worked.
> Well done!
> -- Don

I wish it were all that simple to me, but it turned out to be another
session of eternal yak-shaving for me. My fault I suspect, I should have
known better then to buy a Windows computer.

I downloaded wxWindows 2.8.9 and tried to build it with the supplied  
makefile as
suggested in the installation manual (I have MinGW and MSSY installed):
       make -f makefile.gcc BUILD=debug
but makefile.gcc contains serious bugs.

I then continued to build according to the build instructions on
but these instructions specifically state the contrib should be built and
the first command to do this failed: cd contrib/src, because there is no
such directory 'contrib'.

Trying to install wxHaskell:
> cabal install --global wx
install: /usr/local/lib/wxcore.o
install directory: /usr/local/lib/
install: /usr/local/lib/wxcore.pkg
cat config/wxcore.pkg | sed -e "s|\${wxhlibdir}|/usr/local/lib|" | ghc-pkg  
update -
Reading package info from stdin ... done.
ghc-pkg.exe: /usr/local/lib/imports doesn't exist or isn't a directory  
(use --force to override)
"make": *** [wxcore-register] Error 1
cabal: Error: some packages failed to install:
wx-0.10.5 depends on wxcore-0.10.5 which failed to install.
wxcore-0.10.5 failed during the final install step. The exception was:
exit: ExitFailure 2

The directory /usr/local/lib/imports does exist and contains, amongst  
others, wx*.hi files.

  - Do I really need the contrib part of wxWidgets?
  - Where do I get it?
  - Why does "cabal install --global wx" fail? What can I do about it? (I  
have Administrator rights)

Henk-Jan van Tuyl


More information about the Haskell-Cafe mailing list