[Haskell-cafe] Cabal: error on configure

Don Stewart dons at galois.com
Tue Oct 7 15:54:30 EDT 2008

> OK, I suspect this is a real newbie error, but please have mercy.  I have 
> downloaded and installed cabal (at least it responds to the --help command 
> from the command line).  Yet when I do, say (to give a real example):
> cabal configure parameterized_ data
> (having done he fetch)  I get this error:
> cabal.exe: Using 'build-type" Custom' but there is no Setup.hs or 
> Setup.lhs script.'
> When I download the package manually and look, there is a perfectly 
> servicable Setup.hs script, which I call manually.
> So what gives?
> Dave Barton 

    $ cabal update
    Downloading package list from server

    $ cabal install parameterized-data
    Downloading parameterized-data-0.1.3...
    Configuring parameterized-data-0.1.3...
    Preprocessing library parameterized-data-0.1.3...
    Building parameterized-data-0.1.3...
    [1 of 2] Compiling Data.Param.FSVec ( src/Data/Param/FSVec.hs,
    dist/build/Data/Param/FSVec.o )
    [2 of 2] Compiling Data.Param       ( src/Data/Param.hs,
    dist/build/Data/Param.o )
    /usr/bin/ar: creating dist/build/libHSparameterized-data-0.1.3.a
    Installing library in
    Registering parameterized-data-0.1.3...
    Reading package info from "dist/installed-pkg-config" ... done.
    Saving old package config file... done.
    Writing new package config file... done.

Looks ok to me?

More information about the Haskell-Cafe mailing list