[Haskell-cafe] cabal upgrade

Martin DeMello martindemello at gmail.com
Wed Oct 1 15:52:47 EDT 2008

On Tue, Sep 30, 2008 at 9:01 PM, Duncan Coutts
<duncan.coutts at worc.ox.ac.uk> wrote:
> On Wed, 2008-10-01 at 01:59 +0200, Cetin Sert wrote:
>> A reminder:
>> When I wanted to upgrade to yi, I needed to download the new
>> package list
>> cabal update           #download list of new packages
>> cabal upgrade         #make any upgrades
> Note that 'cabal upgrade' upgrades everything you've currently got
> installed (which in general is not necessarily possible).
> The standard workflow is just:
> cabal update            #download list of new packages
> cabal install yi        #install latest version of yi

$ cabal install yi
Resolving dependencies...
'yi-' is cached.
Configuring yi-
cabal: alex version >=2.0.1 && <3 is required but it could not be found.
cabal: Error: some packages failed to install:
yi- failed during the configure step. The exception was:
exit: ExitFailure 1

$ cabal install yi-gtk
Resolving dependencies...
cabal: cannot configure yi-gtk-0.2.1. It requires sourceview >=0.9.11
There is no available version of sourceview that satisfies >=0.9.11

Trying cabal upgrade didn't fix it - it still throws the same error.


More information about the Haskell-Cafe mailing list