[Haskell-cafe] haddock question

allan a.d.clark at ed.ac.uk
Thu Nov 27 06:52:04 EST 2008

Dear all

I'm trying to locally build the documentation for the haskell-src-exts package and running into a bit of bother.
If I run: cabal haddock
I get the error:
haddock: parse error in doc string

so: cabal haddock -v
Doesn't really provide any extra information, it gives me the exact haddock command-line used but there is still no way (I can see) of obtaining the source file containing the parse error.

So I downloaded via darcs the latest haddock source code and installed that but I get the exact same error message.
I tried grepping in the haddock source code for that particular error message (and portions of it) but I couldn't find it.

Finally I tried running haddock on a single source file:
haddock Language/Haskell/Exts.hs 
and even this gets the exact same error message, which is somewhat bizarre since that file does not contain any documentation strings.

Anyone have any ideas?


The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

More information about the Haskell-Cafe mailing list