[Haskell-cafe] Trouble installing ghc-6.10.1 on linux

Ian Lynagh igloo at earth.li
Tue Nov 11 17:26:19 EST 2008

Hi Bit,

On Mon, Nov 10, 2008 at 03:05:23PM +0200, Bit Connor wrote:
> First I tried the binary version ghc-6.10.1-i386-unknown-linux.tar.bz2
> and I very quickly get this error:
> $ ./configure
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
> checking target system type... i686-pc-linux-gnu
> Which we'll further canonicalise into: i386-unknown-linux
> checking for path to top of build tree... configure: error: cannot
> determine current directory
> $

This probably means your libc is too old for the bindist to work.

Presumably running
    utils/pwd/pwd forwardslash
gives a SIGFPE or similar?

> Next I tried building the source version ghc-6.10.1-src.tar.bz2 using
> ghc 6.6 that is already installed. configure works but make eventually
> dies with:
>   ...
> Configuring ghc-6.10.1...
> cabal-bin: At least the following dependencies are missing:
> Cabal -any,

This is the output of a cabal-bin command, right? Appending -v to the
commandline might shed some light on what's going wrong. Or if that
doesn't help, try "-v 3".


More information about the Haskell-Cafe mailing list