[Haskell-cafe] Re: [Haskell] ANN: random-access-list-0.1

wren ng thornton wren at freegeek.org
Fri Jun 13 16:29:07 EDT 2008

Isaac Dupree wrote:
> "extractHead" is an ugly name for a nevertheless standardish-meaning 
> function... what is it usually called? uncons? headTail? (Data.Sequence, 
> which is meant to be left-right symmetric, calls it "viewr"... except 
> your version doesn't have the Maybe, it's partial instead, fails on 
> empty lists)

Views are nice, but these other functions are needed too. As for 
"extractHead", what about "split"? (cf. Control.Monad.Logic.msplit[1])

[1] http://tinyurl.com/37f4ga

Live well,

More information about the Haskell-Cafe mailing list