[Haskell-cafe] cabal install fail for happs-hsp-template

Thomas Hartman tphyahoo at gmail.com
Mon Jun 2 12:42:08 EDT 2008

Can cabal install be made to work for this package?
thartman at thartman-laptop:~>sudo cabal install happs-hsp-template
[sudo] password for thartman:
cabal: internal error: could not construct a valid install plan.
The proposed (invalid) plan contained the following problems:
Package Cabal is required by several packages, but they require
inconsistent versions:
  package ghc-6.8.2 requires Cabal-
  package plugins-1.2 requires Cabal-1.5.2

thartman at thartman-laptop:~>cabal --version
cabal-install version 0.4.7
using version 1.3.11 of the Cabal library
thartman at thartman-laptop:~>ghc --version
The Glorious Glasgow Haskell Compilation System, version 6.8.2
thartman at thartman-laptop:~>ghc-pkg list | grep -i ghc
    (ghc-6.8.2), haskell-src-, haskell98-, hpc-,

More information about the Haskell-Cafe mailing list