[Haskell-cafe] Cabal + yi + alex problem.

Yann Golanski yann at kierun.org
Wed Jul 30 04:59:35 EDT 2008

Quoth Austin Seipp on Wed, Jul 30, 2008 at 03:45:49 -0500
> Excerpts from Yann Golanski's message of Wed Jul 30 02:34:05 -0500 2008:
> > I cannot seem to be able to install yi via cabal install.  The error I
> > get is as follows.  I suspect alex is not installed in the correct
> > place.  
> > ...
> Hi,
> cabal-install will put installed binaries in $HOME/.cabal/bin by
> default as far as I can tell, you should move the binary somewhere in
> your $PATH if you want cabal-install to pick it up for installing yi.

Well, that indeed sorted that one.  But still no luck:

; sudo cabal install yi
Resolving dependencies...
'yi-0.4.3' is cached.
Configuring yi-0.4.3...
Preprocessing library yi-0.4.3...
Preprocessing executables for yi-0.4.3...
Building yi-0.4.3...

    Could not find module `Graphics.Vty':
          Use -v to see a list of the files searched for.
cabal: Error: some packages failed to install:
yi-0.4.3 failed during the building phase. The exception was:
exit: ExitFailure 1

yann at kierun.org             -= H+ =-             www.kierun.org
   PGP:   009D 7287 C4A7 FD4F 1680  06E4 F751 7006 9DE2 6318
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.haskell.org/pipermail/haskell-cafe/attachments/20080730/376afd2b/attachment.bin

More information about the Haskell-Cafe mailing list