[Haskell-cafe] Trying to install cabal

Tillmann Rendel rendel at daimi.au.dk
Mon Jul 14 03:11:28 EDT 2008

Brandon S. Allbery KF8NH wrote:
>> I have downloaded cabal and am trying to install it but have gotten the
>> following error message:
>> C:\cabal\cabal-install-0.5.1>runghc Setup configure
> Cabal itself is a special case; you need the same version of Cabal 
> already installed to install it via Cabal...
> Just run "make" to bootstrap it, IIRC.

Cabal managed to bootstrap just fine when installed with runhaskell 
Setup.hs ... as usual on my windows machine. (and running make would 
have been a problem). But to install cabal-install (the command line 
interface), you have to install cabal (the library) first.

I assume that in the future, ghc will include cabal-install? Until then, 
it would be nice to have some ad-hoc solution to add cabal-install to a 
fresh installation of ghc (e.g. a tarball containing cabal-install and 
it's dependencies and a build script, or a script which downloads said 
dependencies). Currently, people have to learn dependency chasing and 
manual hackage/cabal installation just to install cabal-install, which 
does a great job at making this skill useless.

Apropos cabal-install: can i make it build documentation during the 
installation process and store them in some central location?


More information about the Haskell-Cafe mailing list