[Haskell-cafe] Re: Compiling Blobs

Peter Verswyvelen bf3 at telenet.be
Thu Jan 17 14:10:28 EST 2008

Hi Miguel!

Thanks for the reply!

Yes, I also took the latest darcs version of wxHaskell, HaXml 1.19.2,
and polyparse.

I had to do some minor tweaks to the Blobs source code (mainly
Text.Parse stuff, no big deal really).

I used wxGTK 2.6.4, --with-opengl and --disable-sharing (otherwise I got
link errors when linking Blobs).

However I'm using GHC 6.8.2 on Fedora 8. BTW what do you think is the
best distro for doing Haskell development?

Now I just switched from Windows to Linux, so this is all very very new
to me. However I do like the Linux way of settings things up, so I'm
planning to dig a bit deeper in the Linux world. Not easy because I know
a lot about Windows development, so giving that up is hard.

I'll take a look at the website you mentioned.

The fact to you have it running gives me confidance it is possible :)


On Thu, 2008-01-17 at 14:51 +0000, Miguel Vilaça wrote:
> Peter Verswyvelen wrote:
> > I'm trying to build http://www.cs.york.ac.uk/fp/darcs/Blobs using GHC
> > 6.8.2. It looks like a good Haskell program to learn from.
> >
> > So far I managed to modify the source code so it makes use of the new
> > HaXML libraries, and after a lot of hacking I could build and link to
> > wxHaskell, but my app crashes (I do get a window however, woohoo)
> >
> > Maybe someone else managed already?
> >
> > Thanks,
> > Peter
> >
> >
> > _______________________________________________
> > Haskell-Cafe mailing list
> > Haskell-Cafe at haskell.org
> > http://www.haskell.org/mailman/listinfo/haskell-cafe
> >   
> Hi Peter,
> I have Blobs compiling and running in my machine.
> Its an Kubuntu Gutsy with GHC 6.6.1 and HaXml 1.19.SOMETHING (I'm using
> a repository version but not yet the current one)
> This implies some minor changes that I've as local patches, that I can
> send to you as soon as I find how to get a file per patch from the
> repository.
> The big issue is always to be able to get wxHaskell compiled and working
> properly.
> I'm currently using a recent (1 or 2 weeks old) version of wxHaskell
> from its official repository  (darcs get
> http://darcs.haskell.org/wxhaskell) and wxGTK 2.6.3
> You can find more information in INblobs (INblobs is done on top of
> Bblobs) webpage : http://haskell.di.uminho.pt/jmvilaca/INblobs/
> or in the wxHaskell mailing list wxhaskell-users at lists.sourceforge.net
> What versions of wxWidgets are you using and in which platform?
> best
> Miguel Vilaca

More information about the Haskell-Cafe mailing list