[Haskell-cafe] Haskell-mode 2.4

Stefan Monnier monnier at iro.umontreal.ca
Thu Jan 10 18:05:48 EST 2008

>> First of all, thanks. My Aqua Emacs (on OS X Leopard) hangs when I
>> send a command like C-c C-l or C-c C-t to the interpreter (I can quit
>> the command using C-g) . Starting the interpreter and using :l from
>> inside it works fine. This is using GHC 6.8 (and I think I also tried
>> 6.6.) What could be the problem?
>> I also tried to eval this but it didn't make a difference:
>> (setq inferior-haskell-find-project-root nil)

> It looks like this is a problem with 6.8.2 as haskell-mode-2.3 has the
> same problem? Seems like the commands being sent to the haskell
> process never reaches it.

Try can you try to look into the nature of the hang?
Is Emacs completely frozen?  Does C-g get you back to something usable?
If so, can you set Options => Enter Debugger on Quit, then reproduce the
problem than hit C-g and show me the backtrace?
If not, can you run Emacs under a debugger and give me a backtrace of
when Emacs is frozen?


More information about the Haskell-Cafe mailing list