[Haskell-cafe] Haskell-mode 2.4

Johan Tibell johan.tibell at gmail.com
Tue Jan 8 16:37:25 EST 2008

On Dec 12, 2007 5:40 AM, Stefan Monnier <monnier at iro.umontreal.ca> wrote:
> * inf-haskell.el tries to find the root of the module hierarchy to determine
>   the root of a project (either by looking for a Cabal file or relying on
>   the `module' declaration line).  If all works well, this will make C-c C-l
>   automatically switch to the root dir, so that dependencies in other
>   directories are automatically found.  If it doesn't, complain and/or set
>   inferior-haskell-find-project-root to nil.

First of all, thanks. My Aqua Emacs (on OS X Leopard) hangs when I
send a command like C-c C-l or C-c C-t to the interpreter (I can quit
the command using C-g) . Starting the interpreter and using :l from
inside it works fine. This is using GHC 6.8 (and I think I also tried
6.6.) What could be the problem?

I also tried to eval this but it didn't make a difference:

(setq inferior-haskell-find-project-root nil)

-- Johan

More information about the Haskell-Cafe mailing list