[Haskell-cafe] ANNOUNCE: Haddock version

David Waern david.waern at gmail.com
Tue Jan 8 09:48:02 EST 2008

2008/1/8, Adrian Hey <ahey at iee.org>:
> Hello,
> I've just tried this with cabal
>  > runghc Setup haddock --hyperlink-source --hscolour-css=..\hscolour.css
> and I get this error..
> Setup: haddock --hyperlink-source requires Haddock version 0.8 or later
> This looks like a bug in cabal rather than the new Haddock to me.
> Can anyone think of an easy workaround?

Yes, you could switch to the darcs version of Cabal, where this has
been fixed. I don't know if a release containing the fix has been


More information about the Haskell-Cafe mailing list